Etiquetas

Imagen

 

Varias vulnerabilidades de seguridad han sido descubiertas en el Linux kernel (Quantal HWE) y afectan al sistema operativo Ubuntu 12.04 LTS (Precise Pangolin), según declaró recientemente Canonical.

La empresa aseguró que la nueva actualziación corrigió algunos problemas en el Linux kernel.

Por ejemplo, se ha descubierto un error en la función xen_iret en la virtualización Xen del Linux kernel. En la plataforma Xen paravirt de 32 bits, un usuario sin privilegios ha explotado este error para provocar una denegación de servicio o incluso obtener privilegios de anfitrión en el sistema operativo.

Las vulnrabilidades de seguridad pueden solucionarse actualizando el sistema a linux-image-3.5.0-27-generic (3.5.0-27.46~precise1).

No olvides reiniciar el ordenador tras terminar la instalación.

Atención: Debido a un inevitable cambio de ABI, los paquetes kernel tienen una nueva versión, lo que te obligará a reinstalar y recompilar todos los módulos kernel de terceros que podrías haber instalado. Asimismo, si utilizas el pack de módulos restringidos de Linux (linux-restricted-modules), tienes que actualizarlo para obtener los módulos que funcionan con la nueva versión de Linux kernel.

 

Fuente: http://news.softpedia.es/Canonical-corrige-las-vulnerabilidades-del-Linux-Kernel-Quantal-HWE-en-Ubuntu-12-04-LTS-344470.html

 

Imagen